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About Datgel CPT Tool  2 
The Datgel CPT Tool gINT Add-In 2 is designed streamline the processing and interpretation of Cone 
Penetration Test and Dissipation Test data: 

¶ Designed for flexibility and user configuration 

¶ ASCII data files in numerous standard and propriety formats may be imported 

¶ Filter rod changes 

¶ Calculate derived parameters 

¶ The soil type and strength may be interpreted based on user defined parameters, and then a 
summary can be transferred to your soil description and consistency/density table 

¶ 46 preconfigured published correlations are calculated, written to the database and ready for 
presentation on your graphs and logs 

¶ User-definable correlation formulas 

¶ Dissipation test analysis 

¶ More than 60 customisable log, graph and fence reports 

¶ User definable line colours, types and scales 

¶ Our CPT processing code has been used to manage tens of thousands of tests by clients 
across the globe 

You need to complete the installation procedure (see Installation and Licensing on page 1) and activate 
(see Datgel Product Licensing System User Guide) before you can use the CPT Tool. 

New in Version 2  

1. 63 preconfigured correlations  

2. Formula Tool for user-definable correlation formulas 

3. Dynamic user definable log, fence and graph reports 

4. User definable line colours, types and scales 

5. Schneider, Randolph, Mayne and Ramsey (2008) soil behaviour type interpretation 

6. Dissipation test analysis 

7. Import of more data file formats: Vertek (*.dat), Pagani (*.cpt), Geomil PlotCPT (*.T*) 

8. Seismic cone 

Support  

12 months support and maintenance is included with the license purchase.  For technical support 
please email support@datgel.com or call +61 2 8202 8600. 

System Requirements  

gINT 

The product runs optimally using gINT 8.2.008 or higher, however it will run using gINT 8.1.2.008 or 
higher. 

mailto:support@datgel.com
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gINT Professional is recommended.  The product will run using gINT Logs, gINT Logs Plus, and gINT 
Professional.  However the tool includes graph and fence reports that can only be used with gINT 
Professional. 

Hardware and Operating System 

Same system requirements as gINT 8.2, see: http://www.gintsoftware.com/products_requirements.html. 

Required Windows Components 

1. Windows Installer 3.1 

2. .NET 3.5 Framework SP1 

Conventions and typography used in this guide  

Note: Tips and additional Information to help you. 

> Used to indicate a series of menu commands. 

e.g. Select File > Open.  

| Used to indicate a gINT Application Group, Application, Table Group or Table , e.g. 
DATA DESIGN | Project Database 

Bold Text Items you must select, command buttons, or items in a list. 

e.g. Navigate to UTILITIES | Convert Projects (4
th

 tab). 

Italics Emphasis Use to emphasize the importance of a point such as parameters. 

e.g. Data Entry ï Check Omit Must Save prompt when save is required 

CAPITALS Names of keys on the keyboard. for example, SHIFT, CTRL, or ALT. 

KEY+KEY Key combinations, for example CTRL+P, or ALT+F4. 

Code Snippet  Indicates a code snippet within a paragraph 

Code sample  Indicates a sample program codes inserted in user guide e.g. 

public override string ToString ()  

File name  or path  Used for formatting file name and paths e.g. di_lib.glb  or  

V: \ 10 gINT \ Datgel Install Files \  

Table_Name Database table name, e.g. POINT_TABLE. 

Field_Name Database field name; e.g. PointID 

Command line Command line, presented exactly as it must be entered e.g. 

cdir 

Field Colours  

Each of the fields in the project tables have been coloured to improve the data entry process as 
indicated below in Table 1. 

http://www.gintsoftware.com/products_requirements.html
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Table 1 - Field Colours  

Field Colour  Field Name and Explanation  

 Yellow gINT Key Field ï mandatory data entry 

 Pastel Purple 
AGS Data ï data associated with the AGS Data 
Interchange format 

 Pastel Green 
Calculated Field ï data is written to this field by Datgelôs 
code 

 Pastel Beige 
Data Entry Field ï data should be entered into this field, 
or data in this field influences the calculation 

 Pastel Red 
Legacy Data Field ï historic data entered here, is from 
typically an old database 

 Pastel Blue 
Output Option ï used to control how the data displayed 
on a report 

 Pastel Orange 
Remark or Metadata Field ï additional data associated 
with the primary information 

 Grey Read-only 

 

Note: The Datgel CPT Tool is built in two versions ï DGD with long table (e.g. CPT_POINT_PARAMETERS) and 
field names and AGS RTA with short AGS-compliant names (e.g. STCS). 

Both names are usually given, although only one is relevant to any given site. Screen images are not 
duplicated and usually show only the DGD version. 
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1 Ins tallation and Licensing  
There are four parts to the installation process: 

¶ DLL program installation 

¶ Merge gINT library objects 

¶ Merging project tables and fields 

¶ Activate the product license 

The first three steps can be completed in any order and are described below. The activation procedure 
must be done last and is described in the Datgel Product Licensing System User Guide. 

1.1 DLL Program Installation  

The CPT Tool requires that the Microsoft .net 3.5 framework is installed on the PC prior to the 
installation of the CPT Tool.  If your PC does not have the .net 3.5 framework SP1 installed, then it will 
be automatically installed during the CPT Tool installation process.  You need local administrator rights 
to the PC to install the CPT Tool.  

To install the CPT Tool: 

¶ Ensure that gINT is closed 

¶ Run the setup.exe file 

¶ Follow the prompts 

In the following screen, you can either accept the default location for the new file, or change it by 
clicking Browse. The Disk Cost button shows the space required versus space available on each of 
your disks.  

 

1.2 Which Database Structure? ï DGD or AGS RTA  

At this point you must decide which CPT Tool database structure to use.  The options are: 
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1. DGD (stands for Datgel Database) with long table (e.g. CPT_POINT_PARAMETERS) and field 
names. 

2. AGS RTA, based on the structure prescribed by the Roads and Traffic Authority of NSW, 
Australia, and the Association of Geotechnical and Geoenvironmental Specialists.   The 
database has short AGS-compliant names (e.g. STCS). 

Unless youôre currently using an AGS RTA style database, we recommend you adopt the DGD 
database. 

1.3 Merge gINT Library Objects  

Note: If youôre in one of the following situations then proceed to Section 1.6 Validate or Activate License. 

In the trial version of the CPT Tool, the library will be locked and you cannot merge any gINT Library Objects 
into your Library file, or make changes to this Library file.  In this case, you have to use the locked library as-
is.   

Steps 1.3 to 1.5 have been done by Datgelôs developers or done previously by you or a colleague. 

If you donôt have existing gINT files then you may wish to just use the example CPT Tool gINT Files provided 
on the DVD. 

If you have purchased the CPT Tool, then you have full access to the library objects, and you may 
proceed with the following steps to merge the gINT Library components into your Library file.  

1. Make a backup copy of your existing library file. By default this is located at: 

C: \ Program Files \ gINT8 \ libraries \  

2. Start gINT and open the library and project file you wish to use the Datgel CPT Tool with. 

3. Select UTILITIES | Lib Merge/Copy. 

4. Browse the Source Library File for datgel  cpt  tool  dgd  lib  #. ##.glb  

5. Check the Query On Overwrite box, then move all source tables, except Material Composite 
Symbols and Titles, to the yellow box on the right side by clicking the >> button. 

 

6. Click Execute.  The process may take several minutes. 

This merges the CPT Tool Add-In menu item, gINT Rules modules, user system data and other library 
tables relevant for the use of the CPT Tool. 
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1.4 Merge gINT Project File Tables and Fields  

1. Open your existing project/data template in DATA DESIGN | Project Database. 

 

2. Select Tables > Import Multiple Tables...  then browse for either file datgel cpt  tool  

dgd  #. ##.gpj or datgel cpt  tool  dgd  #.##.gdt .    

3. At the minimum, select the following tables to import, and click OK. 

 

The other tables are not critical to the operation of the CPT Tool and you may already have 
similar tables in your project file. However many of the gINT reports provided with the CPT 
Tool reference the other tables, and you may need to update the field references in the reports 
to work with your custom project database. 

1.5 Initial Configuration  

Following the library and project merge steps, the following items should be configured: 

1. Configure the Graphic_1 and Graphic_2 fields on DG_CPT_SOIL_CLASS_ZONES library table; see 
4.10 DG_CPT_SOIL_CLASS_ZONES on page 18.  Select the most appropriate graphics in 
your library for each soil type zone. 
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2. Configure the table and field names for Lithology/Stratigraphy and Consistency/Density as 
described in 14.3 Configuration of description and consistency summary transfer on page 82 . 

3. In SYMBOL DESIGN | Bitmap Symbols, import your company logo into the existing symbol 
called LOGO.  This symbol is referenced by all the Tools reports.  Alternatively you can adjust 
the following library entities. 

a) Configure your logo to appear on the log blocks: 
i. DG CPT LOG BASE 2 11X17L 
ii. DG CPT LOG BASE 2 A3L 
iii. DG CPT LOG BASE 2 A4P 
iv. DG CPT LOG BASE 2 LETP 
v. DG CPT LOG BASE 3 A4P 

b) Configure your logo to appear on the General Drawing DG COM FIGURE TITLE BLOCK 

4. Update field and table references as required in the merged CPT Tool gINT reports to work 
with custom gINT project file. 

5. Update the import correspondence files (*.gci) for the numerous CPT formats to work with your 
custom gINT project file. 

6. Assign correct page sizes and printer to reports.  In order to export a report to pdf or other 
image format the correct page size must be assigned. 

a) Ensure a printer driver installed on your pc has A3 and 11x17 size. 
b) Use the command REPORT DESIGN | File > Set printer for reports, pick the printer with 

A3 from the printer list, and select the A3 size reports from the reports list. 
c) Then go to each A3 and 11x17 size report in REPORT DESIGN by changing the yellow 

drop down list.  Display the report properties, File > Page > Properties, and set the page 
size to A3 or 11x17. You may also need to adjust the margins. Click Ok. 

d) Review the page margins and outlines by clicking on Zoom Page, and move to the next 
report. 

1.6 Validate or Activate License  

After installation (and before using the CPT Tool Add-in), validate or activate the user license as 
described in Chapter 2 of the Datgel Product Licensing System User Guide. 
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2 Quick Start  Tutorial  

2.1 Introduction  

This tutorial will introduce you to the basic operations of the CPT Tool; it assumes you have a basic 
understanding of gINT INPUT and OUTPUT.  If this is the first time youôve used gINT then we suggest 

you read the welcome_to_gint_8.pdf  located in this directory C: \ Program Files \ gINT8 \ docs  

and also available from this web page http://www.gintsoftware.com/support_doc.html. 

2.2 Preliminaries  

1. First work your way though section 1 Installation and Licensing. 

2. Start gINT 8, and check youôre running 8.2.008 or 8.1.2.008 or later by reviewing the version 
number on the Help > About gINT dialog.  If youôre running an older update, then you should 
download and install the latest gINT update using Help > Check for gINT Update or manually 
downloading the update from http://www.gintsoftware.com/support_updates_v8.html. 

3. This tutorial will use our standard DGD CPT Tool gINT Files, located on the DVD in folder 

gINT Files \ DGD\ .  If you havenôt done so, copy the folders on the DVD to a location on your 

local or network drives.  You can also use a set of custom gINT files that already have the CPT 
Tool tables and objects merged in, as described in section 1 Installation and Licensing. 

4. Now, open the datgel cpt tool dgd lib X.XX.glb , using File > Change Library. 

5. Create a new project, select the command File > New Project > Clone Data Template..., and 

select the datgel cpt tool dgd X.XX.gdt  file, and click Open.  Then provide the name 

Tutorial 1.gpj  and click Save. 

2.3 Importing CPT and Dissipation Data  

1. Launch the Data Import Tool, by calling the command Add-Ins > Datgel CPT Tool > Data 
Import. 

 

The CPT Tool splash screen should now appear, signifying you are now using the CPT Tool 
license.   

¶ If youôre using a trial license then a form will appear telling you how many uses are left.   

¶ If nothing happens, then double check you have installed the CPT Tool program by 

running the setup.exe  file located in the I nstallation Files  folder on the DVD. 

¶ If you havenôt previously validated your license, i.e. by entering the serial number, license 
number, contact details, and server name in the case of a network license.  Then you will 

http://www.gintsoftware.com/support_doc.html
http://www.gintsoftware.com/support_updates_v8.html
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be prompted to do so now, and you should refer to Chapter 2 of the Datgel Product 

Licensing System User Guide, which was included on the DVD in the Documentation  

folder. 
 

You should now see the Data Import Tool form. 

 

2. In this tutorial we will import a GEF files.  

a) Set File Type to GEF 1.1.0 (*.gef) 
b) Set Overwrite Option to Never 

c) Correspondence File to é\ datgel_cpt_tool_dgd_X.XX_gef_cpt XX.gci .  The gci 

can be found in the gINT Files \ DGD\  folder on the DVD.  The gci file translates the data 

during the import process between a temporary CSV file created by the CPT Tool code and 
the DGD database tables and fields. 
 

Select the Browseé button in the top right of the form, and browse to the \ Example CPT 

Data Files \  folder from the DVD.  Select: "GEF_01.GEF" "GEF_01_D01.GEF" 

"GEF_01_D02.GEF" .  The *D* files are dissipation test files related to the GEF_01.GEF 

file.  The form should now look similar to the screenshot (apart from the folder paths). 

 

 

d) Click Execute.  There will be a short pause while the Datgel code translates the data, then 
you will see a gINT progress form.   
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Finally when the import is complete a gINT Import Log form will display. 
 

 
 
It can be useful to review the Source and Target record counts to confirm the data has 
imported.  The Log also lists over write and lookup warnings.  In this case the warnings are 
of little consequence. 
 
You may now like to step through the tables in the project file, and observe the imported 
data.  Note that some values, such as those on the CPT_GLOBAL_PARAMETERS table are 
default values stored in the data template file we used to make the new project. 

2.4 Configuring Parameters and CPT Data Analysis  

The following information must be entered for the basic CPT Calculations to occur: 

¶ CPT Data - Upper: Test Number, Cone ID, and (optionally) Groundwater Depth 

¶ CPT Data - Lower: Depth, qc, fs, u2 (for CPTU) 

¶ CPT Cone Information: Cone ID, Cone Area Ratio (for CPTU), and Cone Sleeve Offset (used to filter rod 
change noise for fs) 




























































































































































































